2020-02-17T20:39:30.501750+00:00
Incident impacting Upstream Providers

Updated at 14:50 MST: Network partner update "We would like to inform you that the issue with Montreal, Quebec PSTN connectivity has been addressed. All services are now back online as of 16:50 EST."

We thank you for your patience and understanding and apologize for the inconvenience.

Status changed to
Fully Operational
2020-02-17T22:03:36.648797+00:00

Updated at 1:47 PM MST "Please be advised that almost all services are back online with the exception of PSTN calls in Montreal, Quebec. Our platform engineers are working to restore PSTN network connectivity in Montreal, Quebec."

Status remaining
Degraded Performance
2020-02-17T20:48:28.259344+00:00

Updated at 1:38 PM from network partner "Please be advised that we are currently working towards restoring services across our network. Some services are now back online and functional. The root cause of the issue is still being investigated. Affected services: LOCAL ORIGINATION SERVICES - ONTARIO & QUEBEC"

Affected services (some):

Status remaining
Degraded Performance
2020-02-17T20:42:16.822973+00:00

We have a few reports from clients with call completion issues with some inbound and some outbound calls.

Our team has routed around the outbound calling challenges for the most part and continue to monitor for additional inbound and outbound issues. The latest update we have from the network partner provider is:

"We are having an IP-Networking issue and some of our services are not available. Our senior engineers are actively pursuing an immediate resolution."

Our equipment is 100% operational and support is available during this outage.

Status changed to
Degraded Performance
2020-02-17T20:39:30.501772+00:00
Back to Current Status